PYSEC-2025-54
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2025-48942
- Alias
- GHSA-6qc9-v4r8-22xg
Description
vLLM is an inference and serving engine for large language models (LLMs). In versions 0.8.0 up to but excluding 0.9.0, hitting the /v1/completions API with a invalid json_schema as a Guided Param kills the vllm server. This vulnerability is similar GHSA-9hcf-v7m4-6m2j/CVE-2025-48943, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · vllm | introduced 0, fixed 08bf7840780980c7568c573c70a6a8db94fd45ff ; introduced 0.8.0, fixed 0.9.0 |
Références
- https://github.com/vllm-project/vllm/security/advisories/GHSA-6qc9-v4r8-22xg EVIDENCE
- https://github.com/vllm-project/vllm/commit/08bf7840780980c7568c573c70a6a8db94fd45ff FIX
- https://github.com/vllm-project/vllm/pull/17623 REPORT
- https://github.com/vllm-project/vllm/issues/17248 REPORT
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |