PYSEC-2025-55

At a glance

Published
Updated
CVE
CVE-2025-48943
Aliases
GHSA-9hcf-v7m4-6m2j

Description

vLLM is an inference and serving engine for large language models (LLMs). Version 0.8.0 up to but excluding 0.9.0 have a Denial of Service (ReDoS) that causes the vLLM server to crash if an invalid regex was provided while using structured output. This vulnerability is similar to GHSA-6qc9-v4r8-22xg/CVE-2025-48942, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.

Affected packages

PackageVersions
PyPI · vllmintroduced 0, fixed 08bf7840780980c7568c573c70a6a8db94fd45ff ; introduced 0.8.0, fixed 0.9.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database