PYSEC-2026-1137
apache-airflow-providers-apache-drill Improper Input Validation vulnerability
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-39553
- Alias
- GHSA-mq4v-6vg4-796c, PYSEC-2023-136
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Description
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider. Apache Airflow Drill Provider is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection with DrillHook giving an opportunity to read files on the Airflow server. This issue affects Apache Airflow Drill Provider before 2.4.3. It is recommended to upgrade to a version that is not affected.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · apache-airflow-providers-apache-drill | introduced 0, fixed 2.4.3 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2023-39553 ADVISORY
- https://github.com/apache/airflow/pull/33074 WEB
- https://github.com/apache/airflow/commit/394a727ac2c18d58978bf186a7a92923460ec110 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-136.yaml WEB
- https://lists.apache.org/thread/ozpl0opmob49rkcz8svo8wkxyw1395sf WEB
- https://www.openwall.com/lists/oss-security/2023/08/11/1 WEB
- http://www.openwall.com/lists/oss-security/2023/08/11/1 WEB
- https://pypi.org/project/apache-airflow-providers-apache-drill PACKAGE
- https://github.com/advisories/GHSA-mq4v-6vg4-796c ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |