PYSEC-2026-143

At a glance

Published
Updated
CVE
CVE-2026-22773
Aliases
GHSA-grg2-63fw-f2qr
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

vLLM is an inference and serving engine for large language models (LLMs). In versions from 0.6.4 to before 0.12.0, users can crash the vLLM engine serving multimodal models that use the Idefics3 vision model implementation by sending a specially crafted 1x1 pixel image. This causes a tensor dimension mismatch that results in an unhandled runtime error, leading to complete server termination. This issue has been patched in version 0.12.0.

Affected packages

PackageVersions
PyPI · vllmintroduced 0.6.4, fixed 0.12.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database