PYSEC-2026-1775

OAuth2 client ID and secret exposed through the web browser

At a glance

Published
Updated
CVE
CVE-2024-9014
Aliases
GHSA-jm9x-rx9x-wpqj
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Description

pgAdmin versions 8.11 and earlier are vulnerable to a security flaw in OAuth2 authentication. This vulnerability allows an attacker to potentially obtain the client ID and secret, leading to unauthorized access to user data.

Affected packages

PackageVersions
PyPI · pgadmin4introduced 0, fixed 8.12

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database