PYSEC-2026-17

At a glance

Published
Updated
CVE
CVE-2026-30911
Aliases
BIT-airflow-2026-30911, GHSA-8x34-9q3v-h7g8
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Description

Apache Airflow versions 3.1.0 through 3.1.7 missing authorization vulnerability in the Execution API's Human-in-the-Loop (HITL) endpoints that allows any authenticated task instance to read, approve, or reject HITL workflows belonging to any other task instance. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 3.1.0, fixed 3.1.8

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database