PYSEC-2026-1918
setuptools vulnerable to Command Injection via package URL
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2024-6345
- Alias
- BIT-setuptools-2024-6345, GHSA-cx63-2mw6-8hw5
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
A vulnerability in the `package_index` module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · setuptools | introduced 0, fixed 70.0.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2024-6345 ADVISORY
- https://github.com/pypa/setuptools/pull/4332 WEB
- https://github.com/pypa/setuptools/commit/88807c7062788254f654ea8c03427adc859321f0 WEB
- https://github.com/pypa/setuptools PACKAGE
- https://huntr.com/bounties/d6362117-ad57-4e83-951f-b8141c6e7ca5 WEB
- https://lists.debian.org/debian-lts-announce/2024/09/msg00018.html WEB
- https://pypi.org/project/setuptools PACKAGE
- https://github.com/advisories/GHSA-cx63-2mw6-8hw5 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |