PYSEC-2026-2297

At a glance

Published
Updated
CVE
CVE-2026-27893
Aliases
GHSA-7972-pg2x-xr59
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Description

vLLM is an inference and serving engine for large language models (LLMs). Starting in version 0.10.1 and prior to version 0.18.0, two model implementation files hardcode `trust_remote_code=True` when loading sub-components, bypassing the user's explicit `--trust-remote-code=False` security opt-out. This enables remote code execution via malicious model repositories even when the user has explicitly disabled remote code trust. Version 0.18.0 patches the issue.

Affected packages

PackageVersions
PyPI · vllmintroduced 0.10.1, fixed 0.18.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database