PYSEC-2026-2298

At a glance

Published
Updated
CVE
CVE-2026-34756
Aliases
GHSA-3mwp-wvh9-7528
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.19.0, a Denial of Service vulnerability exists in the vLLM OpenAI-compatible API server. Due to the lack of an upper bound validation on the n parameter in the ChatCompletionRequest and CompletionRequest Pydantic models, an unauthenticated attacker can send a single HTTP request with an astronomically large n value. This completely blocks the Python asyncio event loop and causes immediate Out-Of-Memory crashes by allocating millions of request object copies in the heap before the request even reaches the scheduling queue. This vulnerability is fixed in 0.19.0.

Affected packages

PackageVersions
PyPI · vllmintroduced 0.1.0, fixed 0.19.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database