PYSEC-2026-2364

Apache Airflow Celery provider Insertion of Sensitive Information into Log File vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2023-46215
Alias
BIT-airflow-2023-46215, GHSA-666g-rfc5-c9jv, PYSEC-2026-1131
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

Insertion of Sensitive Information into Log File vulnerability in Apache Airflow Celery provider, Apache Airflow. Sensitive information logged as clear text when rediss, amqp, rpc protocols are used as Celery result backend Note: the vulnerability is about the information exposed in the logs not about accessing the logs. This issue affects Apache Airflow Celery provider: from 3.3.0 through 3.4.0; Apache Airflow: from 1.10.0 through 2.6.3. Users are recommended to upgrade Airflow Celery provider to version 3.4.1 and Apache Airlfow to version 2.7.0 which fixes the issue.

Paquets affectés

PaquetVersions
PyPI · apache-airflow-providers-celeryintroduced 3.3.0, fixed 3.4.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database