PYSEC-2026-2368

Apache Airflow missing Certificate Validation

En bref

Publiée
Mise à jour
CVE
CVE-2023-39441
Alias
BIT-airflow-2023-39441, GHSA-5f35-pq34-c87q, PYSEC-2026-1130, PYSEC-2026-2371
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate.  Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability

Paquets affectés

PaquetVersions
PyPI · apache-airflow-providers-imapintroduced 0, fixed 3.3.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database