PYSEC-2026-2371
Apache Airflow missing Certificate Validation
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-39441
- Alias
- BIT-airflow-2023-39441, GHSA-5f35-pq34-c87q, PYSEC-2026-1130, PYSEC-2026-2368
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Description
Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate. Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · apache-airflow-providers-smtp | introduced 0, fixed 1.3.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2023-39441 ADVISORY
- https://github.com/apache/airflow/pull/33070 WEB
- https://github.com/apache/airflow/pull/33075 WEB
- https://github.com/apache/airflow/pull/33108 WEB
- https://github.com/apache/airflow/commit/38fc9cd823feafd8ec61d5d5c7eddb9e9162f755 WEB
- https://github.com/apache/airflow/commit/3bd8f020e8b7bdeb7f618bdbdfb3557f117b29d3 WEB
- https://github.com/apache/airflow/commit/dbacacbd4d476da757de148a4e747924c34fd7fe WEB
- https://github.com/apache/airflow PACKAGE
- https://lists.apache.org/thread/xzp4wgjg2b1o6ylk2595df8bstlbo1lb WEB
- http://www.openwall.com/lists/oss-security/2023/08/23/2 WEB
- https://pypi.org/project/apache-airflow-providers-smtp PACKAGE
- https://github.com/advisories/GHSA-5f35-pq34-c87q ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |