PYSEC-2026-250

At a glance

Published
Updated
CVE
CVE-2026-56340
Aliases
GHSA-mcmc-2m55-j8jj
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. Because PyTorch disables sparse tensor invariant checks by default, an attacker can submit crafted embedding requests with malformed (negative or out-of-bounds) tensor indices, when the prompt-embeds feature is enabled, to trigger crashes or resource exhaustion (denial of service), with potential for out-of-bounds/write-what-where memory corruption. This continues CVE-2025-62164, whose prior fix only disabled the feature by default rather than addressing the root cause.

Affected packages

PackageVersions
PyPI · vllmintroduced 0.10.2, fixed 0.13.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database