PYSEC-2026-2525

OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere

At a glance

Published
Updated
CVE
CVE-2026-42510
Aliases
GHSA-wqpv-c3pp-3m58
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Description

OpenStack Ironic before 35.0.1 allows ipmitool execution in a non-default configuration that has a console interface.

Affected packages

PackageVersions
PyPI · ironicintroduced 0, fixed 35.0.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database