PYSEC-2026-268

Command Injection in Apache Airflow and Apache Airflow MySQL Provider

At a glance

Published
Updated
CVE
CVE-2023-22884
Aliases
BIT-airflow-2023-22884, GHSA-c732-xvv8-g94c, PYSEC-2026-279
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow, Apache Software Foundation Apache Airflow MySQL Provider.This issue affects Apache Airflow: before 2.5.1; Apache Airflow MySQL Provider: before 4.0.0.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 2.5.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database