PYSEC-2026-271
Apache Airflow Hive Provider vulnerable to code injection
At a glance
- Published
- Updated
- CVE
- CVE-2023-28706
- Aliases
- GHSA-5cvg-9pp5-mxcj
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Apache Software Foundation's Apache Airflow Hive Provider before 6.0.0 is vulnerable to improper control of generation of code.
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow-providers-apache-hive | introduced 0, fixed 6.0.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-28706 ADVISORY
- https://github.com/apache/airflow/pull/30212 WEB
- https://github.com/apache/airflow PACKAGE
- https://lists.apache.org/thread/dl20xxd51xvlx0zzc0wzgxfjwgtbbxo3 WEB
- http://www.openwall.com/lists/oss-security/2023/04/07/2 WEB
- https://pypi.org/project/apache-airflow-providers-apache-hive PACKAGE
- https://github.com/advisories/GHSA-5cvg-9pp5-mxcj ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |