PYSEC-2026-274
Apache Airflow Hive Provider vulnerable to Command Injection
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2022-46421
- Alias
- GHSA-rc58-qr9j-cpgw
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider before 5.0.0.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · apache-airflow-providers-apache-hive | introduced 0, fixed 5.0.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2022-46421 ADVISORY
- https://github.com/apache/airflow/pull/28101 WEB
- https://github.com/apache/airflow PACKAGE
- https://lists.apache.org/thread/09twdoyoybldlfj5gvk0qswtofh0rmp4 WEB
- https://pypi.org/project/apache-airflow-providers-apache-hive PACKAGE
- https://github.com/advisories/GHSA-rc58-qr9j-cpgw ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |