PYSEC-2026-275
Apache Airflow Sqoop Provider Improper Input Validation vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2023-25693
- Aliases
- GHSA-j69x-v4wc-3fpf, PYSEC-2023-314
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Improper Input Validation vulnerability in the Apache Airflow Sqoop Provider. This issue affects Apache Airflow Sqoop Provider versions before 3.1.1.
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow-providers-apache-sqoop | introduced 0, fixed 3.1.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-25693 ADVISORY
- https://github.com/apache/airflow/pull/29500 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-314.yaml WEB
- https://lists.apache.org/thread/79qn8g5xbq036f8crb115obvr22l52q4 WEB
- https://pypi.org/project/apache-airflow-providers-apache-sqoop PACKAGE
- https://github.com/advisories/GHSA-j69x-v4wc-3fpf ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |