PYSEC-2026-2867
SQL injection vulnerability in pgAdmin 4 Maintenance Tool
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-7815
- Alias
- GHSA-hp84-p2gq-6fvr
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
SQL injection vulnerability in pgAdmin 4 Maintenance Tool. Four user-supplied JSON fields (buffer_usage_limit, vacuum_parallel, vacuum_index_cleanup, reindex_tablespace) were concatenated directly into the rendered VACUUM/ANALYZE/REINDEX command and passed to psql --command. An authenticated user with the tools_maintenance permission could break out of the option syntax and execute arbitrary SQL on the connected PostgreSQL server. The injected SQL could in turn invoke COPY ... TO PROGRAM to escalate to operating-system command execution on the database host. Fix introduces server-side allow-listing of all four fields and switches reindex_tablespace from manual quoting to the qtIdent filter. This issue affects pgAdmin 4: before 9.15.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 9.15 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2026-7815 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/9898 WEB
- https://github.com/pgadmin-org/pgadmin4/commit/cf53953d9 WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
- https://pypi.org/project/pgadmin4 PACKAGE
- https://github.com/advisories/GHSA-hp84-p2gq-6fvr ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |