PYSEC-2026-3927

Apache Thrift Python bindings have a Improper Validation of Certificate with Host Mismatch vulnerabilit

En bref

Publiée
Mise à jour
CVE
CVE-2026-66053
Alias
BIT-thrift-2026-66053, GHSA-hwrj-9rr4-24xh
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. This replaces CVE-2026-41603

Paquets affectés

PaquetVersions
PyPI · thriftintroduced 0, fixed 0.24.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database