PYSEC-2026-3966

En bref

Publiée
Mise à jour
CVE
CVE-2026-32773
Alias
BIT-spark-2026-32773, GHSA-9437-39hj-3c93
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

Paquets affectés

PaquetVersions
PyPI · pysparkintroduced 3.0.0, fixed 3.5.8

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database