PYSEC-2026-4067

LiteLLM: MCP Proxy Has Improper Authentication

At a glance

Published
Updated
CVE
CVE-2026-12773
Aliases
GHSA-4jcj-7x88-m979
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Description

A weakness has been identified in BerriAI litellm up to 1.59.8. Affected is the function UserAPIKeyAuth of the file litellm/proxy/_experimental/mcp_server/auth/user_api_key_auth_mcp.py of the component MCP Proxy. Executing a manipulation can lead to improper authentication. The attack may be launched remotely. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure.

Affected packages

PackageVersions
PyPI · litellmintroduced 0, fixed 1.84.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database