PYSEC-2026-4185

At a glance

Published
Updated
CVE
CVE-2026-100652
Aliases
GHSA-qff2-492f-9fm4
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

vLLM versions 0.22.0 through 0.23.0 fail to validate stop_token_ids against vocabulary bounds in Rust HTTP and gRPC frontends, allowing out-of-vocabulary token IDs to reach MinTokensLogitsProcessor. Attackers can submit requests with min_tokens greater than zero and out-of-vocabulary stop_token_ids to trigger CUDA tensor indexing failures that leave EngineCore in a fatal state requiring service restart.

Affected packages

PackageVersions
PyPI · vllmintroduced 0.22.0, fixed 0.24.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database