PYSEC-2026-4322

Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package

At a glance

Published
Updated
CVE
CVE-2026-111497
Aliases
BIT-node-2026-111497, BIT-node-min-2026-111497, GHSA-9v8h-qqgm-4m35, PYSEC-2026-4323
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

CVE-2026-111497 ("Node2Shell") is an out-of-bounds write (CWE-787) in Google's Brotli decoder (c/dec/decode.c). DecodeBlockTypeAndLength() returns an ambiguous value for an invalid block switch, and the fast decode path discards it (CWE-252, unchecked return value), so a crafted Brotli stream makes the decoder continue on corrupted state and write past the ring buffer. Upstream rates it CVSS 4.0 9.2 and classifies the impact as potential remote code execution. The vulnerability is in Google's C library, not in Node.js specifically. The PyPI `Brotli` package is Google's CPython binding and compiles the same c/dec/decode.c that has the actual vulnerability. All `Brotli` releases up to and including 1.2.0 ship the vulnerable decoder; 1.2.1 contains the upstream fix (commit 0ed4268a) and differs from 1.2.0 only in that fix plus a version bump. The decoder is reached whenever untrusted Brotli data is decompressed. With `Brotli` installed, common HTTP clients decode Brotli responses automatically (urllib3/requests, httpx with the brotli extra, aiohttp) and services that accept `Content-Encoding: br` request bodies decode inbound data, so the flaw is reachable from attacker-controlled input.

Affected packages

PackageVersions
PyPI · brotliintroduced 0, fixed 1.2.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database