PYSEC-2026-449

pgAdmin 4 Vulnerable to Cross-Site Scripting (XSS) via Query Result Rendering

At a glance

Published
Updated
CVE
CVE-2025-2946
Aliases
GHSA-2rrx-pphc-qfv9
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:H

Description

pgAdmin <= 9.1 is affected by a security vulnerability with Cross-Site Scripting(XSS). If attackers execute any arbitrary HTML/JavaScript in a user's browser through query result rendering, then HTML/JavaScript runs on the browser.

Affected packages

PackageVersions
PyPI · pgadmin4introduced 0, fixed 9.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database