PYSEC-2026-453

pgAdmin 4 vulnerable to Unsafe Deserialization and Remote Code Execution by an Authenticated user

En bref

Publiée
Mise à jour
CVE
CVE-2024-2044
Alias
GHSA-rj98-crf4-g69w
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Description

pgAdmin prior to version 8.4 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. If the server is running on Windows, an unauthenticated attacker can load and deserialize remote pickle objects and gain code execution. If the server is running on POSIX/Linux, an authenticated attacker can upload pickle objects, deserialize them and gain code execution.

Paquets affectés

PaquetVersions
PyPI · pgadmin4introduced 0, fixed 8.4

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database