PYSEC-2026-453
pgAdmin 4 vulnerable to Unsafe Deserialization and Remote Code Execution by an Authenticated user
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2024-2044
- Alias
- GHSA-rj98-crf4-g69w
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Description
pgAdmin prior to version 8.4 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. If the server is running on Windows, an unauthenticated attacker can load and deserialize remote pickle objects and gain code execution. If the server is running on POSIX/Linux, an authenticated attacker can upload pickle objects, deserialize them and gain code execution.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 8.4 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2024-2044 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/7258 WEB
- https://github.com/pgadmin-org/pgadmin4/commit/4e49d752fba72953acceeb7f4aa2e6e32d25853d WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LUYN2JXKKHFSVTASH344TBRGWDH64XQV WEB
- https://www.shielder.com/advisories/pgadmin-path-traversal_leads_to_unsafe_deserialization_and_rce WEB
- https://pypi.org/project/pgadmin4 PACKAGE
- https://github.com/advisories/GHSA-rj98-crf4-g69w ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |