PYSEC-2026-770

OS Command Injection in Apache Airflow

At a glance

Published
Updated
CVE
CVE-2022-40954
Aliases
BIT-airflow-2022-40954, GHSA-45r6-j3cc-6mxx
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Spark Provider, Apache Airflow allows an attacker to read arbtrary files in the task execution context, without write access to DAG files. This issue affects Spark Provider versions prior to 4.0.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case Spark Provider is installed (Spark Provider 4.0.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the Spark Provider version 4.0.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version that has lower version of the Spark Provider installed).

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 2.3.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database