PYSEC-2026-9

En bref

Publiée
Mise à jour
CVE
CVE-2025-68438
Alias
BIT-airflow-2025-68438, GHSA-3qmm-r55x-hpxx
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

In Apache Airflow versions before 3.1.6, when rendered template fields in a Dag exceed [core] max_templated_field_length, sensitive values could be exposed in cleartext in the Rendered Templates UI. This occurred because serialization of those fields used a secrets masker instance that did not include user-registered mask_secret() patterns, so secrets were not reliably masked before truncation and display. Users are recommended to upgrade to 3.1.6 or later, which fixes this issue

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 3.1.0, fixed 3.1.6

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database