CVE-2017-3731
Truncated packet could crash via OOB read
HIGH 7.5
En bref
- Source
- NVD
- EPSS
- EPSS 57.32 % · centile 99 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- openssl
- Statut NVD
- Modified
Description
If an SSL/TLS server or client is running on a 32-bit host, and a specific cipher is being used, then a truncated packet can cause that server or client to perform an out-of-bounds read, usually resulting in a crash. For OpenSSL 1.1.0, the crash can be triggered when using CHACHA20/POLY1305; users should upgrade to 1.1.0d. For Openssl 1.0.2, the crash can be triggered when using RC4-MD5; users who have not disabled that algorithm should update to 1.0.2k.
Faiblesses (CWE)
- CWE-125 — Lecture hors limites
Références
- https://access.redhat.com/errata/RHSA-2018:2185
- https://access.redhat.com/errata/RHSA-2018:2186
- https://security.netapp.com/advisory/ntap-20171019-0002/
- http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html
- http://www.securityfocus.com/bid/95813
- http://rhn.redhat.com/errata/RHSA-2017-0286.html
- https://security.FreeBSD.org/advisories/FreeBSD-SA-17:02.openssl.asc
- https://www.openssl.org/news/secadv/20170126.txt
- http://www.securitytracker.com/id/1037717
- http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
- https://www.tenable.com/security/tns-2017-04
- https://source.android.com/security/bulletin/pixel/2017-11-01
- https://security.gentoo.org/glsa/201702-07
- http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
- http://www.debian.org/security/2017/dsa-3773
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbhf03838en_us
- https://access.redhat.com/errata/RHSA-2018:2187
- https://github.com/openssl/openssl/commit/00d965474b22b54e4275232bc71ee0c699c5cd21
- https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
- https://security.paloaltonetworks.com/CVE-2017-3731
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 5.0 | AV:N/AC:L/Au:N/C:N/I:N/A:P | NVD · nvd@nist.gov (Primary) |
Références européennes
- ENISA EUVD · EUVD-2017-12848
- GCVE · GCVE-0-2017-3731
Avis du CERT-FR
- CERTFR-2018-AVI-343 — Multiples vulnérabilités dans les produits Fortinet · cert.ssi.gouv.fr
- CERTFR-2017-AVI-367 — Multiples vulnérabilités dans Oracle MySQL · cert.ssi.gouv.fr
- CERTFR-2017-AVI-212 — Multiples vulnérabilités dans les produits Juniper · cert.ssi.gouv.fr
- CERTFR-2017-AVI-122 — Multiples vulnérabilités dans Oracle MySQL · cert.ssi.gouv.fr
- CERTFR-2017-AVI-121 — Multiples vulnérabilités dans Oracle Linux and Virtualization · cert.ssi.gouv.fr
- CERTFR-2017-AVI-035 — Multiples vulnérabilités dans les produits Cisco · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:openssl:openssl:1.1.0a:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.1.0b:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.1.0c:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2:beta1:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2:beta2:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2:beta3:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2a:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2b:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2c:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2d:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2e:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2f:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2h:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2i:*:*:*:*:*:*:*cpe:2.3:a:openssl:openssl:1.0.2j:*:*:*:*:*:*:*cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*≥ 4.0.0 ≤ 4.1.2cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:*≥ 4.2.0 < 4.7.3cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*≥ 5.0.0 ≤ 5.12.0cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*≥ 6.0.0 ≤ 6.8.1cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:*≥ 6.9.0 < 6.9.5cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*≥ 7.0.0 < 7.5.0
Produits affectés
| Produit | Versions |
|---|---|
| OpenSSL · OpenSSL | affected openssl-1.1.0 ; affected openssl-1.1.0a ; affected openssl-1.1.0b ; affected openssl-1.1.0c ; affected openssl-1.0.2 ; affected openssl-1.0.2a |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |