CVE-2018-1000079

At a glance

Severity
Not available
EPSS
EPSS 2.78 % · percentile 86 (2026-10-27)
State
PUBLISHED
Published
Updated
Assigner
mitre
NVD status
Modified

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.

Scores

VersionScoreVectorScored by
CVSS 3.0MEDIUM 5.5CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:NNVD · nvd@nist.gov (Primary)
CVSS 2.0MEDIUM 4.3AV:N/AC:M/Au:N/C:N/I:P/A:NNVD · nvd@nist.gov (Primary)

Weaknesses (CWE)

Advisories

European references

CERT-FR advisories

Affected configurations (NVD CPE)

Affected products

ProductVersions
affected n/a

References

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD