CVE-2018-1000136
En bref
- Source
- NVD
- EPSS
- EPSS 5.08 % · centile 92 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- mitre
- Statut NVD
- Modified
Rechercher sur…
Description
Electron version 1.7 up to 1.7.12; 1.8 up to 1.8.3 and 2.0.0 up to 2.0.0-beta.3 contains an improper handling of values vulnerability in Webviews that can result in remote code execution. This attack appear to be exploitable via an app which allows execution of 3rd party code AND disallows node integration AND has not specified if webview is enabled/disabled. This vulnerability appears to have been fixed in 1.7.13, 1.8.4, 2.0.0-beta.4.
Faiblesses (CWE)
- CWE-20 — Validation d'entrée incorrecte
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.0 | HIGH 8.1 | CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 6.8 | AV:N/AC:M/Au:N/C:P/I:P/A:P | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-8xwg-wv7v-4vqp — Electron Vulnerable to Code Execution by Re-Enabling Node.js Integration
Références européennes
- ENISA EUVD · EUVD-2018-0178
- GCVE · GCVE-0-2018-1000136
Configurations affectées (CPE NVD)
cpe:2.3:a:electronjs:electron:*:*:*:*:*:*:*:*≥ 1.7.0 ≤ 1.7.12cpe:2.3:a:electronjs:electron:*:*:*:*:*:*:*:*> 1.8.0 ≤ 1.8.3cpe:2.3:a:electronjs:electron:2.0.0:*:*:*:*:*:*:*cpe:2.3:a:electronjs:electron:2.0.0:beta1:*:*:*:*:*:*cpe:2.3:a:electronjs:electron:2.0.0:beta2:*:*:*:*:*:*cpe:2.3:a:electronjs:electron:2.0.0:beta3:*:*:*:*:*:*cpe:2.3:a:electronjs:electron:2.0.0:beta4:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| affected n/a |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |