CVE-2019-11253
Kubernetes API Server JSON/YAML parsing vulnerable to resource exhaustion attack
HIGH 7.5
En bref
- Source
- NVD
- EPSS
- EPSS 25.94 % · centile 98 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- kubernetes
- Statut NVD
- Analyzed
Description
Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.
Faiblesses (CWE)
Références
- https://github.com/kubernetes/kubernetes/issues/83253
- https://groups.google.com/forum/#%21topic/kubernetes-security-announce/jk8polzSUxs
- https://access.redhat.com/errata/RHSA-2019:3239
- https://security.netapp.com/advisory/ntap-20191031-0006/
- https://access.redhat.com/errata/RHSA-2019:3811
- https://access.redhat.com/errata/RHSA-2019:3905
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | kubernetes |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · jordan@liggitt.net (Secondary) |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 5.0 | AV:N/AC:L/Au:N/C:N/I:N/A:P | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-pmqp-h87c-mr78 — XML Entity Expansion and Improper Input Validation in Kubernetes API server
- GO-2022-0703 — XML Entity Expansion and Improper Input Validation in Kubernetes API server in k8s.io/kubernetes
Références européennes
- ENISA EUVD · EUVD-2021-1151
- GCVE · GCVE-0-2019-11253
Avis du CERT-FR
- CERTFR-2025-AVI-0279 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2022-AVI-591 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:*≥ 1.1.0 ≤ 1.12.10cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:*≥ 1.13.0 < 1.13.12cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:*≥ 1.14.0 < 1.14.8cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:*≥ 1.15.0 < 1.15.5cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:*≥ 1.16.0 < 1.16.2cpe:2.3:a:redhat:openshift_container_platform:3.9:*:*:*:*:*:*:*cpe:2.3:a:redhat:openshift_container_platform:3.10:*:*:*:*:*:*:*cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| Kubernetes · Kubernetes | affected prior to 1.13.12 ; affected prior to 1.14.8 ; affected prior to 1.15.5 ; affected prior to 1.16.2 ; affected 1.1 ; affected 1.2 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |