CVE-2019-1551
rsaz_512_sqr overflow bug on x86_64
MEDIUM 5.3
En bref
- Source
- NVD
- EPSS
- EPSS 14.30 % · centile 97 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- openssl
- Statut NVD
- Modified
Description
There is an overflow bug in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH512 are considered just feasible. However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway. Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME. Fixed in OpenSSL 1.1.1e (Affected 1.1.1-1.1.1d). Fixed in OpenSSL 1.0.2u (Affected 1.0.2-1.0.2t).
Faiblesses (CWE)
- CWE-190 — Débordement d'entier
Références
- https://seclists.org/bugtraq/2019/Dec/39
- https://www.debian.org/security/2019/dsa-4594
- https://seclists.org/bugtraq/2019/Dec/46
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00030.html
- https://security.gentoo.org/glsa/202004-10
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XVEP3LAK4JSPRXFO4QF4GG2IVXADV3SO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DDHOAATPWJCXRNFMJ2SASDBBNU5RJONY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/EXDDAOWSAIEFQNBHWYE6PPYFV4QXGMCD/
- https://usn.ubuntu.com/4376-1/
- https://www.oracle.com/security-alerts/cpujul2020.html
- https://www.tenable.com/security/tns-2019-09
- https://www.openssl.org/news/secadv/20191206.txt
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=419102400a2811582a7a3d4a4e317d72e5ce0a8f
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=f1c5eea8a817075d31e43f5876993c6710238c98
- https://security.netapp.com/advisory/ntap-20191210-0001/
- http://packetstormsecurity.com/files/155754/Slackware-Security-Advisory-openssl-Updates.html
- https://www.tenable.com/security/tns-2020-03
- https://usn.ubuntu.com/4504-1/
- https://www.oracle.com/security-alerts/cpujan2021.html
- https://www.tenable.com/security/tns-2020-11
- https://www.debian.org/security/2021/dsa-4855
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://www.tenable.com/security/tns-2021-10
- https://lists.debian.org/debian-lts-announce/2022/03/msg00023.html
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 5.0 | AV:N/AC:L/Au:N/C:P/I:N/A:N | NVD · nvd@nist.gov (Primary) |
Références européennes
- ENISA EUVD · EUVD-2019-10108
- GCVE · GCVE-0-2019-1551
Avis du CERT-FR
- CERTFR-2026-AVI-0199 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0262 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0051 — Multiples vulnérabilités dans les produits Juniper · cert.ssi.gouv.fr
- CERTFR-2022-AVI-916 — Multiples vulnérabilités dans les produits Juniper · cert.ssi.gouv.fr
- CERTFR-2021-AVI-430 — Multiples vulnérabilités dans Tenable LCE · cert.ssi.gouv.fr
- CERTFR-2020-AVI-840 — Multiples vulnérabilités dans Tenable Tenable.sc · cert.ssi.gouv.fr
- CERTFR-2020-AVI-691 — Multiples vulnérabilités dans les produits Juniper · cert.ssi.gouv.fr
- CERTFR-2020-AVI-435 — Multiples vulnérabilités dans Oracle MySQL · cert.ssi.gouv.fr
- CERTFR-2020-AVI-420 — Multiples vulnérabilités dans les produits Juniper · cert.ssi.gouv.fr
- CERTFR-2020-AVI-249 — Multiples vulnérabilités dans Tenable Nessus · cert.ssi.gouv.fr
- CERTFR-2019-AVI-657 — Multiples vulnérabilités dans Tenable.sc · cert.ssi.gouv.fr
- CERTFR-2019-AVI-611 — Vulnérabilité dans OpenSSL · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*≥ 1.0.2 ≤ 1.0.2tcpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*≥ 1.1.1 ≤ 1.1.1dcpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:*cpe:2.3:a:oracle:enterprise_manager_ops_center:12.4.0.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:mysql_enterprise_monitor:*:*:*:*:*:*:*:*≤ 4.0.12cpe:2.3:a:oracle:mysql_enterprise_monitor:*:*:*:*:*:*:*:*≥ 8.0.0 ≤ 8.0.20cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.56:*:*:*:*:*:*:*cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.57:*:*:*:*:*:*:*cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.58:*:*:*:*:*:*:*cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:a:tenable:log_correlation_engine:*:*:*:*:*:*:*:*< 6.0.9
Produits affectés
| Produit | Versions |
|---|---|
| OpenSSL · OpenSSL | affected Fixed in OpenSSL 1.1.1e (Affected 1.1.1-1.1.1d) ; affected Fixed in OpenSSL 1.0.2u (Affected 1.0.2-1.0.2t) |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |