CVE-2020-11023

Potential XSS vulnerability in jQuery

MEDIUM 6.9CISA KEV ↗Exploited per ENISA since 2025-01-23

At a glance

Source
NVD
EPSS
EPSS 84.89 % · percentile 100 ()
State
PUBLISHED
Published
Updated
Assigner
GitHub_M
NVD status
Analyzed

Description

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Weaknesses (CWE)

  • CWE-79 — Cross-site Scripting (XSS)

References

Scores

VersionScoreVectorScored by
CVSS 3.1MEDIUM 6.9CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:NGitHub_M
CVSS 3.1MEDIUM 6.9CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:NNVD · security-advisories@github.com (Secondary)
CVSS 3.1MEDIUM 6.1CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NNVD · nvd@nist.gov (Primary)
CVSS 2.0MEDIUM 4.3AV:N/AC:M/Au:N/C:N/I:P/A:NNVD · nvd@nist.gov (Primary)

Advisories

European references

CERT-FR advisories

Affected configurations (NVD CPE)

Affected products

ProductVersions
jquery · jQueryaffected >= 1.0.3, < 3.5.0

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
CISA Known Exploited VulnerabilitiesCC0 1.0
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD