CVE-2020-11025

Authenticated cross-site scripting (XSS) in WordPress Customizer

MEDIUM 5.8

At a glance

Source
NVD
EPSS
EPSS 1.53 % · percentile 75 ()
State
PUBLISHED
Published
Updated
Assigner
GitHub_M
NVD status
Modified

Description

In affected versions of WordPress, a cross-site scripting (XSS) vulnerability in the navigation section of Customizer allows JavaScript code to be executed. Exploitation requires an authenticated user. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).

Weaknesses (CWE)

  • CWE-79 — Improper Neutralization of Input During Web Page Generation

References

Scores

VersionScoreVectorScored by
CVSS 3.1MEDIUM 5.8CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:NGitHub_M
CVSS 3.1MEDIUM 5.8CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:NNVD · security-advisories@github.com (Secondary)
CVSS 3.1MEDIUM 5.4CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NNVD · nvd@nist.gov (Primary)
CVSS 2.0LOW 3.5AV:N/AC:M/Au:S/C:N/I:P/A:NNVD · nvd@nist.gov (Primary)

European references

Affected configurations (NVD CPE)

Affected products

ProductVersions
WordPress · WordPressaffected >= 5.4.0, < 5.4.1 ; affected >= 5.3.0, < 5.3.3 ; affected >= 5.2.0, < 5.2.6 ; affected >= 5.1.0, < 5.1.5 ; affected >= 5.0.0, < 5.0.9 ; affected >= 4.9.0, < 4.9.14

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD