Specially crafted filenames in WordPress leading to XSS (WordPress WordPress)
En bref
- Source
- NVD
- EPSS
- EPSS 2.09 % · centile 82 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Modified
Rechercher sur…
Description
In affected versions of WordPress, files with a specially crafted name when uploaded to the Media section can lead to script execution upon accessing the file. This requires an authenticated user with privileges to upload files. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
Faiblesses (CWE)
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.7 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N | GitHub_M |
| CVSS 3.1 | HIGH 8.7 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | MEDIUM 5.4 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | LOW 3.5 | AV:N/AC:M/Au:S/C:N/I:P/A:N | NVD · nvd@nist.gov (Primary) |
Références européennes
- ENISA EUVD · EUVD-2020-3411
- GCVE · GCVE-0-2020-11026
Configurations affectées (CPE NVD)
cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 3.7 < 3.7.33cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 3.8 < 3.8.33cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 3.9 < 3.9.31cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.0 < 4.0.30cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.1 < 4.1.30cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.2 < 4.2.27cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.3 < 4.3.23cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.4 < 4.4.22cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.5 < 4.5.21cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.6 < 4.6.18cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.7 < 4.7.17cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.8 < 4.8.13cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 4.9 < 4.9.14cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.0 < 5.0.9cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.1 < 5.1.5cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.2 < 5.2.6cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*≥ 5.3 < 5.3.3cpe:2.3:a:wordpress:wordpress:5.4:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| WordPress · WordPress | affected >= 5.4.0, < 5.4.1 ; affected >= 5.3.0, < 5.3.3 ; affected >= 5.2.0, < 5.2.6 ; affected >= 5.1.0, < 5.1.5 ; affected >= 5.0.0, < 5.0.9 ; affected >= 4.9.0, < 4.9.14 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |