Cross-site scripting (XSS) in Search block in WordPress (WordPress WordPress)

CVE-2020-11030
MEDIUM 6.4

En bref

Source
NVD
EPSS
EPSS 1.44 % · centile 73 ()
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
GitHub_M
Statut NVD
Modified

Description

In affected versions of WordPress, a special payload can be crafted that can lead to scripts getting executed within the search block of the block editor. This requires an authenticated user with the ability to add content. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).

Faiblesses (CWE)

  • CWE-707 — Improper Neutralization
  • CWE-79 — Injection de code indirecte (XSS)

Références

Scores

VersionScoreVecteurÉvalué par
CVSS 3.1MEDIUM 6.4CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NGitHub_M
CVSS 3.1MEDIUM 6.4CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:NNVD · security-advisories@github.com (Secondary)
CVSS 3.1MEDIUM 5.4CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NNVD · nvd@nist.gov (Primary)
CVSS 2.0LOW 3.5AV:N/AC:M/Au:S/C:N/I:P/A:NNVD · nvd@nist.gov (Primary)

Références européennes

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
WordPress · WordPressaffected >= 5.4.0, < 5.4.1 ; affected >= 5.3.0, < 5.3.3 ; affected >= 5.2.0, < 5.2.6 ; affected >= 5.1.0, < 5.1.5 ; affected >= 5.0.0, < 5.0.9 ; affected >= 4.9.0, < 4.9.14

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD