CVE-2020-8927
Buffer overflow in Brotli library
MEDIUM 5.3
At a glance
- Source
- NVD
- EPSS
- EPSS 3.22 % · percentile 88 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- NVD status
- Modified
Description
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
Weaknesses (CWE)
References
- https://github.com/google/brotli/releases/tag/v1.0.9
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00108.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MMBKACMLSRX7JJSKBTR35UOEP2WFR6QP/
- https://usn.ubuntu.com/4568-1/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WW62OZEY2GHJL4JCOLJRBSRETXDHMWRK/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/J4E265WKWKYMK2RYYSIXBEGZTDY5IQE6/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M4VCDOJGL6BK3HB4XRD2WETBPYX2ITF6/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/W23CUADGMVMQQNFKHPHXVP7RPZJZNN6I/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/356JOYTWW4BWSZ42SEFLV7NYHL3S3AEH/
- https://lists.debian.org/debian-lts-announce/2020/12/msg00003.html
- https://www.debian.org/security/2020/dsa-4801
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZXEQ3GQVELA2T4HNZG7VPMS2HDVXMJRG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MQLM7ABVCYJLF6JRPF3M3EBXW63GNC27/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4TOGTZ2ZWDH662ZNFFSZVL3M5AJXV6JF/
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N | |
| CVSS 3.1 | MEDIUM 5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N | NVD · cve-coordination@google.com (Secondary) |
| CVSS 3.1 | MEDIUM 6.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 6.4 | AV:N/AC:L/Au:N/C:N/I:P/A:P | NVD · nvd@nist.gov (Primary) |
Advisories
- GHSA-5v8v-66v8-mwm7 — Integer overflow in the bundled Brotli C library
- GO-2025-3726 — IO::Compress::Brotli versions prior to 0.007 for Perl have an integer overflow in the bundled Brotli C library in github.com/google/brotli
- PYSEC-2020-29 — A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a
European references
- ENISA EUVD · EUVD-2020-0057
- GCVE · GCVE-0-2020-8927
CERT-FR advisories
- CERTFR-2022-AVI-227 — Multiples vulnérabilités dans les produits Microsoft · cert.ssi.gouv.fr
- CERTFR-2022-AVI-226 — Multiples vulnérabilités dans Microsoft .Net · cert.ssi.gouv.fr
- CERTFR-2021-AVI-791 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:google:brotli:*:*:*:*:*:*:*:*< 1.0.8cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:*cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:*cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:*cpe:2.3:a:microsoft:.net:*:*:*:*:*:*:*:*≥ 5.0 ≤ 5.0.14cpe:2.3:a:microsoft:.net_core:*:*:*:*:*:*:*:*≥ 3.1 ≤ 3.1.22cpe:2.3:a:microsoft:powershell:*:*:*:*:*:*:*:*≥ 7.0 < 7.0.9cpe:2.3:a:microsoft:powershell:*:*:*:*:*:*:*:*≥ 7.1 < 7.1.6cpe:2.3:a:microsoft:powershell:*:*:*:*:*:*:*:*≥ 7.2 < 7.2.2cpe:2.3:a:microsoft:visual_studio_2019:*:*:*:*:*:*:*:*≥ 16.0 ≤ 16.11cpe:2.3:a:microsoft:visual_studio_2022:*:*:*:*:*:*:*:*≥ 17.0 ≤ 17.0.7cpe:2.3:a:microsoft:visual_studio_2022:17.1:*:*:*:*:*:*:*
Affected products
| Product | Versions |
|---|---|
| Google LLC · Brotli | affected stable ≤ 1.0.7 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |