CVE-2021-23840
Integer overflow in CipherUpdate
En bref
- Source
- NVD
- EPSS
- EPSS 50.73 % · centile 99 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- openssl
- Statut NVD
- Modified
Description
Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).
Faiblesses (CWE)
- CWE-190 — Débordement d'entier
Références
- https://www.openssl.org/news/secadv/20210216.txt
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=6a51b9e1d0cf0bf8515f7201b68fb0a3482b3dc1
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=9b1129239f3ebb1d1c98ce9ed41d5c9476c47cb2
- https://www.debian.org/security/2021/dsa-4855
- https://security.gentoo.org/glsa/202103-03
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://www.tenable.com/security/tns-2021-10
- https://www.tenable.com/security/tns-2021-09
- https://security.netapp.com/advisory/ntap-20210219-0009/
- https://www.tenable.com/security/tns-2021-03
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://www.oracle.com//security-alerts/cpujul2021.html
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44846
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://kc.mcafee.com/corporate/index?page=content&id=SB10366
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://security.netapp.com/advisory/ntap-20240621-0006/
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CISA-ADP |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · nvd@nist.gov (Primary) |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
| CVSS 2.0 | MEDIUM 5.0 | AV:N/AC:L/Au:N/C:N/I:N/A:P | NVD · nvd@nist.gov (Primary) |
Références européennes
- ENISA EUVD · EUVD-2021-1843
- GCVE · GCVE-0-2021-23840
Avis du CERT-FR
- CERTFR-2026-AVI-0326 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0316 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0199 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0180 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0051 — Multiples vulnérabilités dans les produits Juniper · cert.ssi.gouv.fr
- CERTFR-2022-AVI-916 — Multiples vulnérabilités dans les produits Juniper · cert.ssi.gouv.fr
- CERTFR-2022-AVI-650 — Multiples vulnérabilités dans les produits Juniper · cert.ssi.gouv.fr
- CERTFR-2022-AVI-272 — Multiples vulnérabilités dans IBM QRadar · cert.ssi.gouv.fr
- CERTFR-2022-AVI-216 — Multiples vulnérabilités dans les produits Siemens · cert.ssi.gouv.fr
- CERTFR-2022-AVI-054 — Multiples vulnérabilités dans Oracle Systems · cert.ssi.gouv.fr
- CERTFR-2021-AVI-430 — Multiples vulnérabilités dans Tenable LCE · cert.ssi.gouv.fr
- CERTFR-2021-AVI-395 — Multiples vulnérabilités dans IBM Spectrum Control · cert.ssi.gouv.fr
- CERTFR-2021-AVI-374 — Multiples vulnérabilités dans Tenable Nessus · cert.ssi.gouv.fr
- CERTFR-2021-AVI-313 — Multiples vulnérabilités dans Stormshield Management Center · cert.ssi.gouv.fr
- CERTFR-2021-AVI-208 — Multiples vulnérabilités dans Tenable Nessus Agent · cert.ssi.gouv.fr
- CERTFR-2021-AVI-157 — Multiples vulnérabilités dans Tenable.sc · cert.ssi.gouv.fr
- CERTFR-2021-AVI-124 — Multiples vulnérabilités dans OpenSSL · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*≥ 1.0.2 < 1.0.2ycpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*≥ 1.1.1 < 1.1.1jcpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:a:tenable:log_correlation_engine:*:*:*:*:*:*:*:*< 6.0.8cpe:2.3:a:tenable:nessus_network_monitor:5.11.0:*:*:*:*:*:*:*cpe:2.3:a:tenable:nessus_network_monitor:5.11.1:*:*:*:*:*:*:*cpe:2.3:a:tenable:nessus_network_monitor:5.12.0:*:*:*:*:*:*:*cpe:2.3:a:tenable:nessus_network_monitor:5.12.1:*:*:*:*:*:*:*cpe:2.3:a:tenable:nessus_network_monitor:5.13.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:business_intelligence:5.5.0.0.0:*:*:*:enterprise:*:*:*cpe:2.3:a:oracle:business_intelligence:5.9.0.0.0:*:*:*:enterprise:*:*:*cpe:2.3:a:oracle:business_intelligence:12.2.1.3.0:*:*:*:enterprise:*:*:*cpe:2.3:a:oracle:business_intelligence:12.2.1.4.0:*:*:*:enterprise:*:*:*cpe:2.3:a:oracle:communications_cloud_native_core_policy:1.15.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:enterprise_manager_for_storage_management:13.4.0.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:enterprise_manager_ops_center:12.4.0.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:graalvm:19.3.5:*:*:*:enterprise:*:*:*cpe:2.3:a:oracle:graalvm:20.3.1.2:*:*:*:enterprise:*:*:*cpe:2.3:a:oracle:graalvm:21.0.0.2:*:*:*:enterprise:*:*:*cpe:2.3:a:oracle:jd_edwards_enterpriseone_tools:*:*:*:*:*:*:*:*< 9.2.6.0cpe:2.3:a:oracle:jd_edwards_world_security:a9.4:*:*:*:*:*:*:*cpe:2.3:a:oracle:mysql_server:*:*:*:*:*:*:*:*< 5.7.33cpe:2.3:a:oracle:mysql_server:*:*:*:*:*:*:*:*≥ 8.0.15 < 8.0.23cpe:2.3:a:oracle:nosql_database:*:*:*:*:*:*:*:*< 20.3cpe:2.3:a:mcafee:epolicy_orchestrator:*:*:*:*:*:*:*:*< 5.10.0cpe:2.3:a:mcafee:epolicy_orchestrator:5.10.0:-:*:*:*:*:*:*cpe:2.3:a:mcafee:epolicy_orchestrator:5.10.0:update_1:*:*:*:*:*:*cpe:2.3:a:mcafee:epolicy_orchestrator:5.10.0:update_10:*:*:*:*:*:*cpe:2.3:a:mcafee:epolicy_orchestrator:5.10.0:update_2:*:*:*:*:*:*cpe:2.3:a:mcafee:epolicy_orchestrator:5.10.0:update_3:*:*:*:*:*:*cpe:2.3:a:mcafee:epolicy_orchestrator:5.10.0:update_4:*:*:*:*:*:*cpe:2.3:a:mcafee:epolicy_orchestrator:5.10.0:update_5:*:*:*:*:*:*cpe:2.3:a:mcafee:epolicy_orchestrator:5.10.0:update_6:*:*:*:*:*:*cpe:2.3:a:mcafee:epolicy_orchestrator:5.10.0:update_7:*:*:*:*:*:*cpe:2.3:a:mcafee:epolicy_orchestrator:5.10.0:update_8:*:*:*:*:*:*cpe:2.3:a:mcafee:epolicy_orchestrator:5.10.0:update_9:*:*:*:*:*:*cpe:2.3:o:fujitsu:m10-1_firmware:*:*:*:*:*:*:*:*< xcp2410cpe:2.3:o:fujitsu:m10-4_firmware:*:*:*:*:*:*:*:*< xcp2410cpe:2.3:o:fujitsu:m10-4s_firmware:*:*:*:*:*:*:*:*< xcp2410cpe:2.3:o:fujitsu:m12-1_firmware:*:*:*:*:*:*:*:*< xcp2410- +15 autres
Produits affectés
| Produit | Versions |
|---|---|
| OpenSSL · OpenSSL | affected Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i) ; affected Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x) |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |