CVE-2021-3711
SM2 Decryption Buffer Overflow
En bref
- Source
- NVD
- EPSS
- EPSS 87.82 % · centile 100 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- openssl
- Statut NVD
- Modified
Description
In order to decrypt SM2 encrypted data an application is expected to call the API function EVP_PKEY_decrypt(). Typically an application will call this function twice. The first time, on entry, the "out" parameter can be NULL and, on exit, the "outlen" parameter is populated with the buffer size required to hold the decrypted plaintext. The application can then allocate a sufficiently sized buffer and call EVP_PKEY_decrypt() again, but this time passing a non-NULL value for the "out" parameter. A bug in the implementation of the SM2 decryption code means that the calculation of the buffer size required to hold the plaintext returned by the first call to EVP_PKEY_decrypt() can be smaller than the actual size required by the second call. This can lead to a buffer overflow when EVP_PKEY_decrypt() is called by the application a second time with a buffer that is too small. A malicious attacker who is able present SM2 content for decryption to an application could cause attacker chosen data to overflow the buffer by up to a maximum of 62 bytes altering the contents of other data held after the buffer, possibly changing application behaviour or causing the application to crash. The location of the buffer is application dependent but is typically heap allocated. Fixed in OpenSSL 1.1.1l (Affected 1.1.1-1.1.1k).
Faiblesses (CWE)
- CWE-120 — Copie de tampon sans vérification de taille (débordement classique)
Références
- https://www.openssl.org/news/secadv/20210824.txt
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=59f5e75f3bced8fc0e130d72a3f582cf7b480b46
- https://www.debian.org/security/2021/dsa-4963
- https://lists.apache.org/thread.html/r18995de860f0e63635f3008fd2a6aca82394249476d21691e7c59c9e%40%3Cdev.tomcat.apache.org%3E
- http://www.openwall.com/lists/oss-security/2021/08/26/2
- https://lists.apache.org/thread.html/rad5d9f83f0d11fb3f8bb148d179b8a9ad7c6a17f18d70e5805a713d1%40%3Cdev.tomcat.apache.org%3E
- https://security.netapp.com/advisory/ntap-20210827-0010/
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://www.tenable.com/security/tns-2021-16
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://security.netapp.com/advisory/ntap-20211022-0003/
- https://www.tenable.com/security/tns-2022-02
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://security.gentoo.org/glsa/202209-02
- https://security.gentoo.org/glsa/202210-02
- https://security.netapp.com/advisory/ntap-20240621-0006/
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | CRITICAL 9.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | HIGH 7.5 | AV:N/AC:L/Au:N/C:P/I:P/A:P | NVD · nvd@nist.gov (Primary) |
Références européennes
- ENISA EUVD · EUVD-2022-2673
- GCVE · GCVE-0-2021-3711
Avis du CERT-FR
- CERTFR-2026-AVI-0199 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0442 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0180 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0145 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0363 — Multiples vulnérabilités dans les produits Schneider · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0214 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2022-AVI-928 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2022-AVI-916 — Multiples vulnérabilités dans les produits Juniper · cert.ssi.gouv.fr
- CERTFR-2022-AVI-429 — Multiples vulnérabilités dans Nessus Network Monitor · cert.ssi.gouv.fr
- CERTFR-2022-AVI-216 — Multiples vulnérabilités dans les produits Siemens · cert.ssi.gouv.fr
- CERTFR-2022-AVI-006 — Multiples vulnérabilités dans les produits Tenable · cert.ssi.gouv.fr
- CERTFR-2021-AVI-943 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2021-AVI-863 — Multiples vulnérabilités dans les produits Microsoft · cert.ssi.gouv.fr
- CERTFR-2021-AVI-801 — Multiples vulnérabilités dans Oracle MySQL · cert.ssi.gouv.fr
- CERTFR-2021-AVI-760 — Vulnérabilité dans Stormshield Network Security · cert.ssi.gouv.fr
- CERTFR-2021-AVI-747 — Multiples vulnérabilités dans les produits Synology · cert.ssi.gouv.fr
- CERTFR-2021-AVI-729 — Multiples vulnérabilités dans Tenable · cert.ssi.gouv.fr
- CERTFR-2021-AVI-656 — Multiples vulnérabilités dans OpenSSL · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*≥ 1.1.1 < 1.1.1lcpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:*cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:windows:*:*cpe:2.3:a:netapp:clustered_data_ontap:-:*:*:*:*:*:*:*cpe:2.3:a:netapp:clustered_data_ontap_antivirus_connector:-:*:*:*:*:*:*:*cpe:2.3:a:netapp:e-series_santricity_os_controller:*:*:*:*:*:*:*:*≥ 11.0 ≤ 11.50.2cpe:2.3:a:netapp:hci_management_node:-:*:*:*:*:*:*:*cpe:2.3:a:netapp:manageability_software_development_kit:-:*:*:*:*:*:*:*cpe:2.3:a:netapp:oncommand_insight:-:*:*:*:*:*:*:*cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:*cpe:2.3:a:netapp:santricity_smi-s_provider:-:*:*:*:*:*:*:*cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:*cpe:2.3:a:netapp:solidfire:-:*:*:*:*:*:*:*cpe:2.3:a:netapp:storage_encryption:-:*:*:*:*:*:*:*cpe:2.3:a:oracle:communications_cloud_native_core_security_edge_protection_proxy:1.7.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:communications_cloud_native_core_unified_data_repository:1.15.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:communications_session_border_controller:8.4:*:*:*:*:*:*:*cpe:2.3:a:oracle:communications_session_border_controller:9.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:communications_unified_session_manager:8.2.5:*:*:*:*:*:*:*cpe:2.3:a:oracle:communications_unified_session_manager:8.4.5:*:*:*:*:*:*:*cpe:2.3:a:oracle:enterprise_communications_broker:3.2.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:enterprise_communications_broker:3.3.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:enterprise_session_border_controller:8.4:*:*:*:*:*:*:*cpe:2.3:a:oracle:enterprise_session_border_controller:9.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:essbase:*:*:*:*:*:*:*:*< 11.1.2.4.47cpe:2.3:a:oracle:essbase:*:*:*:*:*:*:*:*≥ 21.1 < 21.3cpe:2.3:a:oracle:health_sciences_inform_publisher:6.2.1.1:*:*:*:*:*:*:*cpe:2.3:a:oracle:health_sciences_inform_publisher:6.3.1.1:*:*:*:*:*:*:*cpe:2.3:a:oracle:jd_edwards_enterpriseone_tools:*:*:*:*:*:*:*:*< 9.2.6.3cpe:2.3:a:oracle:jd_edwards_world_security:a9.4:*:*:*:*:*:*:*cpe:2.3:a:oracle:mysql_connectors:*:*:*:*:*:*:*:*≤ 8.0.27cpe:2.3:a:oracle:mysql_enterprise_monitor:*:*:*:*:*:*:*:*≤ 8.0.25cpe:2.3:a:oracle:mysql_server:*:*:*:*:*:*:*:*≥ 5.7.0 ≤ 5.7.35cpe:2.3:a:oracle:mysql_server:*:*:*:*:*:*:*:*≥ 8.0.0 ≤ 8.0.26cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.57:*:*:*:*:*:*:*cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.58:*:*:*:*:*:*:*cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.59:*:*:*:*:*:*:*cpe:2.3:a:oracle:zfs_storage_appliance_kit:8.8:*:*:*:*:*:*:*- +2 autres
Produits affectés
| Produit | Versions |
|---|---|
| OpenSSL · OpenSSL | affected Fixed in OpenSSL 1.1.1l (Affected 1.1.1-1.1.1k) |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |