CVE-2021-38153

Timing Attack Vulnerability for Apache Kafka Connect and Clients

MEDIUM 5.9

At a glance

Source
NVD
EPSS
EPSS 6.20 % · percentile 93 ()
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Modified

Description

Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

Weaknesses (CWE)

References

Scores

VersionScoreVectorScored by
CVSS 3.1MEDIUM 5.9CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NNVD · nvd@nist.gov (Primary)
CVSS 2.0MEDIUM 4.3AV:N/AC:M/Au:N/C:P/I:N/A:NNVD · nvd@nist.gov (Primary)

Advisories

European references

CERT-FR advisories

Affected configurations (NVD CPE)

Affected products

ProductVersions
Apache Software Foundation · Apache Kafkaaffected Apache Kafka 2.0.x ≤ 2.0.1 ; affected Apache Kafka 2.1.x ≤ 2.1.1 ; affected Apache Kafka 2.2.x ≤ 2.2.2 ; affected Apache Kafka 2.3.x ≤ 2.3.1 ; affected Apache Kafka 2.4.x ≤ 2.4.1 ; affected Apache Kafka 2.5.x ≤ 2.5.1

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD