CVE-2021-41165
HTML comments vulnerability allowing to execute JavaScript code
HIGH 8.2
At a glance
- Source
- NVD
- EPSS
- EPSS 1.57 % · percentile 75 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Modified
Description
CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.
Weaknesses (CWE)
- CWE-79 — Cross-site Scripting (XSS)
References
- https://github.com/ckeditor/ckeditor4/blob/major/CHANGES.md#ckeditor-417
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-7h26-63m7-qhf2
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://www.drupal.org/sa-core-2021-011
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujul2022.html
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.2 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L | GitHub_M |
| CVSS 3.1 | HIGH 8.2 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | MEDIUM 5.4 | CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | LOW 3.5 | AV:N/AC:M/Au:S/C:N/I:P/A:N | NVD · nvd@nist.gov (Primary) |
Advisories
- GHSA-7h26-63m7-qhf2 — HTML comments vulnerability allowing to execute JavaScript code
European references
- ENISA EUVD · EUVD-2021-2315
- GCVE · GCVE-0-2021-41165
CERT-FR advisories
- CERTFR-2024-AVI-0992 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2022-AVI-366 — Multiples vulnérabilités dans Oracle PeopleSoft · cert.ssi.gouv.fr
- CERTFR-2022-AVI-363 — Multiples vulnérabilités dans Oracle Database Server · cert.ssi.gouv.fr
- CERTFR-2021-AVI-883 — Multiples vulnérabilités dans Drupal · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:ckeditor:ckeditor:*:*:*:*:*:*:*:*< 4.17.0cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*≥ 8.9.0 < 8.9.20cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*≥ 9.1.0 < 9.1.14cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*≥ 9.2.0 < 9.2.9cpe:2.3:a:oracle:agile_product_lifecycle_management:9.3.6:*:*:*:*:*:*:*cpe:2.3:a:oracle:application_express:*:*:*:*:*:*:*:*< 22.1cpe:2.3:a:oracle:banking_apis:*:*:*:*:*:*:*:*≥ 18.1 ≤ 18.3cpe:2.3:a:oracle:banking_apis:19.1:*:*:*:*:*:*:*cpe:2.3:a:oracle:banking_apis:19.2:*:*:*:*:*:*:*cpe:2.3:a:oracle:banking_apis:20.1:*:*:*:*:*:*:*cpe:2.3:a:oracle:banking_apis:21.1:*:*:*:*:*:*:*cpe:2.3:a:oracle:banking_digital_experience:*:*:*:*:*:*:*:*≥ 18.1 ≤ 18.3cpe:2.3:a:oracle:banking_digital_experience:19.1:*:*:*:*:*:*:*cpe:2.3:a:oracle:banking_digital_experience:19.2:*:*:*:*:*:*:*cpe:2.3:a:oracle:banking_digital_experience:20.1:*:*:*:*:*:*:*cpe:2.3:a:oracle:banking_digital_experience:21.1:*:*:*:*:*:*:*cpe:2.3:a:oracle:commerce_guided_search:11.3.2:*:*:*:*:*:*:*cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.58:*:*:*:*:*:*:*cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.59:*:*:*:*:*:*:*cpe:2.3:a:oracle:webcenter_portal:12.2.1.3.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:webcenter_portal:12.2.1.4.0:*:*:*:*:*:*:*
Affected products
| Product | Versions |
|---|---|
| ckeditor · ckeditor4 | affected < 4.17.0 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |