CVE-2021-41184
XSS in the `of` option of the `.position()` util
MEDIUM 6.5
En bref
- Source
- NVD
- EPSS
- EPSS 40.77 % · centile 99 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Modified
Description
jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of the `of` option of the `.position()` util from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `of` option is now treated as a CSS selector. A workaround is to not accept the value of the `of` option from untrusted sources.
Faiblesses (CWE)
- CWE-79 — Injection de code indirecte (XSS)
Références
- https://blog.jqueryui.com/2021/10/jquery-ui-1-13-0-released/
- https://github.com/jquery/jquery-ui/security/advisories/GHSA-gpqq-952q-5327
- https://github.com/jquery/jquery-ui/commit/effa323f1505f2ce7a324e4f429fa9032c72f280
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/O74SXYY7RGXREQDQUDQD4BPJ4QQTD2XQ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SNXA7XRKGINWSUIPIZ6ZBCTV6N3KSHES/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NXIUUBRVLA4E7G7MMIKCEN75YN7UFERW/
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://security.netapp.com/advisory/ntap-20211118-0004/
- https://www.drupal.org/sa-core-2022-001
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://www.tenable.com/security/tns-2022-09
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HVKIOWSXL2RF2ULNAP7PHESYCFSZIJE3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SGSY236PYSFYIEBRGDERLA7OSY6D7XL4/
- https://lists.debian.org/debian-lts-announce/2023/08/msg00040.html
- http://seclists.org/fulldisclosure/2024/Aug/37
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 6.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N | GitHub_M |
| CVSS 3.1 | MEDIUM 6.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | MEDIUM 6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 4.3 | AV:N/AC:M/Au:N/C:N/I:P/A:N | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-gpqq-952q-5327 — XSS in the `of` option of the `.position()` util in jquery-ui
Références européennes
- ENISA EUVD · EUVD-2021-2204
- GCVE · GCVE-0-2021-41184
Avis du CERT-FR
- CERTFR-2026-AVI-1165 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0737 — Multiples vulnérabilités dans les produits SAP · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0701 — Multiples vulnérabilités dans Splunk · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0671 — Multiples vulnérabilités dans Moodle · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0219 — Multiples vulnérabilités dans IBM Sterling B2B Integrator · cert.ssi.gouv.fr
- CERTFR-2022-AVI-993 — Multiples vulnérabilités dans Tenable Nessus · cert.ssi.gouv.fr
- CERTFR-2022-AVI-962 — Multiples vulnérabilités dans Tenable Nessus · cert.ssi.gouv.fr
- CERTFR-2022-AVI-904 — Multiples vulnérabilités dans les produits SAP · cert.ssi.gouv.fr
- CERTFR-2022-AVI-712 — Multiples vulnérabilités dans IBM QRadar SIEM · cert.ssi.gouv.fr
- CERTFR-2022-AVI-658 — Multiples vulnérabilités dans Oracle PeopleSoft · cert.ssi.gouv.fr
- CERTFR-2022-AVI-654 — Multiples vulnérabilités dans Oracle Database Server · cert.ssi.gouv.fr
- CERTFR-2022-AVI-504 — Multiples vulnérabilités dans Tenable Nessus · cert.ssi.gouv.fr
- CERTFR-2022-AVI-429 — Multiples vulnérabilités dans Nessus Network Monitor · cert.ssi.gouv.fr
- CERTFR-2022-AVI-386 — Multiples vulnérabilités dans IBM QRadar SIEM · cert.ssi.gouv.fr
- CERTFR-2022-AVI-370 — Multiples vulnérabilités dans Tenable.sc · cert.ssi.gouv.fr
- CERTFR-2022-AVI-369 — Multiples vulnérabilités dans Oracle WebLogic Server · cert.ssi.gouv.fr
- CERTFR-2022-AVI-365 — Multiples vulnérabilités dans Oracle MySQL · cert.ssi.gouv.fr
- CERTFR-2022-AVI-239 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2022-AVI-205 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:jqueryui:jquery_ui:*:*:*:*:*:jquery:*:*< 1.13.0cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:*cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*cpe:2.3:o:netapp:h300s_firmware:-:*:*:*:*:*:*:*cpe:2.3:o:netapp:h500s_firmware:-:*:*:*:*:*:*:*cpe:2.3:o:netapp:h700s_firmware:-:*:*:*:*:*:*:*cpe:2.3:o:netapp:h300e_firmware:-:*:*:*:*:*:*:*cpe:2.3:o:netapp:h500e_firmware:-:*:*:*:*:*:*:*cpe:2.3:o:netapp:h700e_firmware:-:*:*:*:*:*:*:*cpe:2.3:o:netapp:h410s_firmware:-:*:*:*:*:*:*:*cpe:2.3:o:netapp:h410c_firmware:-:*:*:*:*:*:*:*cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*≥ 7.0 < 7.86cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*≥ 9.2.0 < 9.2.11cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*≥ 9.3.0 < 9.3.3cpe:2.3:a:tenable:tenable.sc:*:*:*:*:*:*:*:*< 5.21.0cpe:2.3:a:oracle:agile_product_lifecycle_management:9.3.6:*:*:*:*:*:*:*cpe:2.3:a:oracle:application_express:*:*:*:*:*:*:*:*< 22.1.1cpe:2.3:a:oracle:banking_platform:2.9.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:banking_platform:2.12.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:big_data_spatial_and_graph:*:*:*:*:*:*:*:*< 23.1cpe:2.3:a:oracle:big_data_spatial_and_graph:23.1:*:*:*:*:*:*:*cpe:2.3:a:oracle:communications_interactive_session_recorder:6.4:*:*:*:*:*:*:*cpe:2.3:a:oracle:communications_operations_monitor:4.3:*:*:*:*:*:*:*cpe:2.3:a:oracle:communications_operations_monitor:4.4:*:*:*:*:*:*:*cpe:2.3:a:oracle:communications_operations_monitor:5.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:hospitality_inventory_management:9.1.0:*:*:*:*:*:*:*cpe:2.3:a:oracle:hospitality_materials_control:18.1:*:*:*:*:*:*:*cpe:2.3:a:oracle:hospitality_suite8:*:*:*:*:*:*:*:*≥ 8.11.0 ≤ 8.14.0cpe:2.3:a:oracle:hospitality_suite8:8.10.2:*:*:*:*:*:*:*cpe:2.3:a:oracle:jd_edwards_enterpriseone_tools:*:*:*:*:*:*:*:*≤ 9.2.6.3cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.58:*:*:*:*:*:*:*cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.59:*:*:*:*:*:*:*cpe:2.3:a:oracle:policy_automation:*:*:*:*:*:*:*:*≥ 12.2.0 ≤ 12.2.25cpe:2.3:a:oracle:primavera_unifier:*:*:*:*:*:*:*:*≥ 17.7 ≤ 17.12cpe:2.3:a:oracle:primavera_unifier:18.8:*:*:*:*:*:*:*cpe:2.3:a:oracle:primavera_unifier:19.12:*:*:*:*:*:*:*cpe:2.3:a:oracle:primavera_unifier:20.12:*:*:*:*:*:*:*cpe:2.3:a:oracle:primavera_unifier:21.12:*:*:*:*:*:*:*- +5 autres
Produits affectés
| Produit | Versions |
|---|---|
| jquery · jquery-ui | affected < 1.13.0 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |