CVE-2021-4192
Use After Free in vim/vim
MEDIUM 5.5
En bref
- Source
- NVD
- EPSS
- EPSS 1.85 % · centile 79 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- @huntrdev
- Statut NVD
- Modified
Description
vim is vulnerable to Use After Free
Faiblesses (CWE)
- CWE-416 — Utilisation après libération
Références
- https://huntr.dev/bounties/6dd9cb2e-a940-4093-856e-59b502429f22
- https://github.com/vim/vim/commit/4c13e5e6763c6eb36a343a2b8235ea227202e952
- http://www.openwall.com/lists/oss-security/2022/01/15/1
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3FH2J57GDA2WMBS6J56F6QQRA6BXQQFZ/
- https://lists.debian.org/debian-lts-announce/2022/03/msg00018.html
- https://support.apple.com/kb/HT213183
- http://seclists.org/fulldisclosure/2022/Mar/29
- https://support.apple.com/kb/HT213256
- http://seclists.org/fulldisclosure/2022/May/35
- https://support.apple.com/kb/HT213343
- http://seclists.org/fulldisclosure/2022/Jul/14
- https://security.gentoo.org/glsa/202208-32
- https://lists.debian.org/debian-lts-announce/2022/11/msg00009.html
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.0 | MEDIUM 5.5 | CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N | @huntrdev |
| CVSS 3.1 | HIGH 7.8 | CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H | NVD · nvd@nist.gov (Primary) |
| CVSS 3.0 | MEDIUM 5.5 | CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N | NVD · security@huntr.dev (Secondary) |
| CVSS 2.0 | MEDIUM 6.8 | AV:N/AC:M/Au:N/C:P/I:P/A:P | NVD · nvd@nist.gov (Primary) |
Références européennes
- ENISA EUVD · EUVD-2021-34052
- GCVE · GCVE-0-2021-4192
Avis du CERT-FR
- CERTFR-2022-AVI-665 — Multiples vulnérabilités dans les produits Apple · cert.ssi.gouv.fr
- CERTFR-2022-AVI-467 — Multiples vulnérabilités dans le noyau Linux de SUSE · cert.ssi.gouv.fr
- CERTFR-2022-AVI-466 — Multiples vulnérabilités dans les produits Apple · cert.ssi.gouv.fr
- CERTFR-2022-AVI-330 — Multiples vulnérabilités dans Stormshield Network Security · cert.ssi.gouv.fr
- CERTFR-2022-AVI-243 — Multiples vulnérabilités dans les produits Apple · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:*< 8.2.3949cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:*:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2020-001:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-001:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-002:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-003:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-004:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-005:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-006:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-007:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-008:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-001:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-002:*:*:*:*:*:*cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-003:*:*:*:*:*:*cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:*< 12.3cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:*≥ 11.0 < 11.6.6cpe:2.3:o:apple:macos:10.15.7:security_update_2022-004:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| vim · vim/vim | affected unspecified < 8.2 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |