Cross-site Scripting in Prism (PrismJS prism)

CVE-2022-23647
HIGH 7.5

En bref

Source
NVD
EPSS
EPSS 1.43 % · centile 73 ()
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
GitHub_M
Statut NVD
Modified

Description

Prism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.

Faiblesses (CWE)

  • CWE-79 — Injection de code indirecte (XSS)

Références

Scores

VersionScoreVecteurÉvalué par
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:LGitHub_M
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:LNVD · security-advisories@github.com (Secondary)
CVSS 3.1MEDIUM 6.1CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NNVD · nvd@nist.gov (Primary)
CVSS 2.0MEDIUM 4.3AV:N/AC:M/Au:N/C:N/I:P/A:NNVD · nvd@nist.gov (Primary)

Avis

Références européennes

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
PrismJS · prismaffected >= 1.14.0, < 1.27.0

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD