CVE-2022-3566
Linux Kernel TCP tcp_setsockopt race condition
En bref
- Sévérité
- LOW 2.1
- EPSS
- EPSS 0.74 % · centile 55 (2026-10-27)
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- VulDB
- Statut NVD
- Analyzed
Description
A vulnerability was identified in Linux Kernel up to 4.19.316/5.4.278/5.10.220/5.15.161. This impacts the function tcp_getsockopt/tcp_setsockopt of the component TCP Handler. Such manipulation leads to race condition. A high complexity level is associated with this attack. The exploitability is said to be difficult. The vulnerability was introduced in 2.6.12, commit 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 ("Linux-2.6.12-rc2"). Upgrading to version 4.19.317, 5.4.279, 5.10.221, 5.15.162 and 6.1 will fix this issue. The name of the patch is fcd31dd8291b23d713245947ec2b2d99ef07aef2/3b32f265805a49071e2c4568a524398ba22bf93c/d529193eae979a7bf2255cd9fe68b7af7a1c91b3/5bb642cc3355ffd3c8bca0a8bd8e6e65bcc2091c/f49cd2f4d6170d27a2c61f1fecb03d8a70c91f57. The affected component should be upgraded.
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 4.0 | LOW 2.1 | CVSS:4.0/AV:A/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X | VulDB |
| CVSS 3.1 | MEDIUM 4.6 | CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C | VulDB |
| CVSS 3.0 | MEDIUM 4.6 | CVSS:3.0/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C | VulDB |
| CVSS 2.0 | MEDIUM 4.0 | AV:A/AC:H/Au:S/C:P/I:P/A:P/E:ND/RL:OF/RC:C | VulDB |
| CVSS 4.0 | LOW 2.1 | CVSS:4.0/AV:A/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X | NVD · cna@vuldb.com (Secondary) |
| CVSS 3.1 | MEDIUM 4.6 | CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L | NVD · cna@vuldb.com (Secondary) |
| CVSS 3.1 | HIGH 7.1 | CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 4.0 | AV:A/AC:H/Au:S/C:P/I:P/A:P | NVD · cna@vuldb.com (Secondary) |
Faiblesses (CWE)
Références européennes
- ENISA EUVD · EUVD-2022-42930
- GCVE · GCVE-0-2022-3566
Avis du CERT-FR
- CERTFR-2024-AVI-0115 — Multiples vulnérabilités dans le noyau Linux de RedHat · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0027 — Multiples vulnérabilités dans les produits Juniper Networks · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0686 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0627 — Multiples vulnérabilités dans IBM Spectrum · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0544 — Multiples vulnérabilités dans le noyau Linux de SUSE · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0507 — Multiples vulnérabilités dans le noyau Linux de SUSE · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0489 — Multiples vulnérabilités dans le noyau Linux de SUSE · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0474 — Multiples vulnérabilités dans le noyau Linux de SUSE · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0393 — Multiples vulnérabilités dans le noyau Linux de RedHat · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0383 — Multiples vulnérabilités dans le noyau Linux de RedHat · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0148 — Multiples vulnérabilités dans le noyau Linux de SUSE · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0010 — Multiples vulnérabilités dans le noyau Linux d'Ubuntu · cert.ssi.gouv.fr
- CERTFR-2022-AVI-1125 — Multiples vulnérabilités dans le noyau Linux de SUSE · cert.ssi.gouv.fr
- CERTFR-2022-AVI-1122 — Multiples vulnérabilités dans le noyau Linux de SUSE · cert.ssi.gouv.fr
- CERTFR-2022-AVI-1115 — Multiples vulnérabilités dans le noyau Linux de SUSE · cert.ssi.gouv.fr
- CERTFR-2022-AVI-1113 — Multiples vulnérabilités dans le noyau Linux d'Ubuntu · cert.ssi.gouv.fr
- CERTFR-2022-AVI-1075 — Multiples vulnérabilités dans le noyau Linux d'Ubuntu · cert.ssi.gouv.fr
- CERTFR-2022-AVI-1070 — Multiples vulnérabilités dans le noyau Linux d'Ubuntu · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*≥ 2.6.12 < 4.19.317cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*≥ 4.20 < 5.4.279cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*≥ 5.5 < 5.10.221cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*≥ 5.11 < 5.15.162
Produits affectés
| Produit | Versions |
|---|---|
| Linux · Kernel | affected 4.19.316 ; affected 5.4.278 ; affected 5.10.220 ; affected 5.15.161 ; unaffected 4.19.317 ; unaffected 5.4.279 |
Références
- https://vuldb.com/vuln/211089
- https://vuldb.com/vuln/211089/cti
- https://vuldb.com/cve/CVE-2022-3566
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=f49cd2f4d6170d27a2c61f1fecb03d8a70c91f57
- https://www.kernel.org/
- https://vuldb.com/?id.211089
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |