CVE-2022-36023
Remote denial of service in Hyperledger Fabric Gateway
HIGH 7.0
En bref
- Source
- NVD
- EPSS
- EPSS 1.13 % · centile 66 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Modified
Description
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
Faiblesses (CWE)
- CWE-20 — Validation d'entrée incorrecte
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.0 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H | GitHub_M |
| CVSS 3.1 | HIGH 7.0 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | MEDIUM 5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-qj6r-fhrc-jj5r — Remote denial of service in Hyperledger Fabric Gateway
Références européennes
- ENISA EUVD · EUVD-2022-7152
- GCVE · GCVE-0-2022-36023
Configurations affectées (CPE NVD)
cpe:2.3:a:hyperledger:fabric:*:*:*:*:*:*:*:*< 2.4.6
Produits affectés
| Produit | Versions |
|---|---|
| hyperledger · fabric | affected < 2.4.6 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |