HTTP/2 HPACK integer overflow and buffer allocation (eclipse jetty.project)
En bref
- Source
- NVD
- EPSS
- EPSS 4.83 % · centile 92 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Modified
Rechercher sur…
Description
Eclipse Jetty provides a web server and servlet container. In versions 11.0.0 through 11.0.15, 10.0.0 through 10.0.15, and 9.0.0 through 9.4.52, an integer overflow in `MetaDataBuilder.checkSize` allows for HTTP/2 HPACK header values to exceed their size limit. `MetaDataBuilder.java` determines if a header name or value exceeds the size limit, and throws an exception if the limit is exceeded. However, when length is very large and huffman is true, the multiplication by 4 in line 295 will overflow, and length will become negative. `(_size+length)` will now be negative, and the check on line 296 will not be triggered. Furthermore, `MetaDataBuilder.checkSize` allows for user-entered HPACK header value sizes to be negative, potentially leading to a very large buffer allocation later on when the user-entered size is multiplied by 2. This means that if a user provides a negative length value (or, more precisely, a length value which, when multiplied by the 4/3 fudge factor, is negative), and this length value is a very large positive number when multiplied by 2, then the user can cause a very large buffer to be allocated on the server. Users of HTTP/2 can be impacted by a remote denial of service attack. The issue has been fixed in versions 11.0.16, 10.0.16, and 9.4.53. There are no known workarounds.
Faiblesses (CWE)
Références
- https://github.com/eclipse/jetty.project/security/advisories/GHSA-wgh7-54f2-x98r
- https://github.com/eclipse/jetty.project/pull/9634
- https://github.com/eclipse/jetty.project/releases/tag/jetty-10.0.16
- https://github.com/eclipse/jetty.project/releases/tag/jetty-11.0.16
- https://github.com/eclipse/jetty.project/releases/tag/jetty-9.4.53.v20231009
- http://www.openwall.com/lists/oss-security/2023/10/18/4
- https://lists.debian.org/debian-lts-announce/2023/10/msg00045.html
- https://www.debian.org/security/2023/dsa-5540
- https://security.netapp.com/advisory/ntap-20231116-0011/
- https://security.netapp.com/advisory/ntap-20240621-0006/
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | GitHub_M |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-wgh7-54f2-x98r — HTTP/2 HPACK integer overflow and buffer allocation
Références européennes
- ENISA EUVD · EUVD-2023-2828
- GCVE · GCVE-0-2023-36478
Avis du CERT-FR
- CERTFR-2026-AVI-1165 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2025-AVI-0255 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-1081 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0459 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0385 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0228 — Multiples vulnérabilités dans IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0199 — Multiples vulnérabilités dans IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0180 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0113 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0074 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0057 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0031 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2023-AVI-1062 — Multiples vulnérabilités dans Juniper Secure Analytics · cert.ssi.gouv.fr
- CERTFR-2023-AVI-1055 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0976 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:eclipse:jetty:*:*:*:*:*:*:*:*≥ 9.3.0 < 9.4.53cpe:2.3:a:eclipse:jetty:*:*:*:*:*:*:*:*≥ 10.0.0 < 10.0.16cpe:2.3:a:eclipse:jetty:*:*:*:*:*:*:*:*≥ 11.0.0 < 11.0.16cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*< 2.414.3cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*< 2.428cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| eclipse · jetty.project | affected >= 10.0.0, < 10.0.16 ; affected >= 11.0.0, < 11.0.16 ; affected >= 9.3.0, < 9.4.53 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |