SQUID-2023:4 Denial of Service in SSL Certificate validation (squid-cache squid)
En bref
- Source
- NVD
- EPSS
- EPSS 4.05 % · centile 91 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Modified
Rechercher sur…
Description
Squid is a caching proxy for the Web. Due to an Improper Validation of Specified Index bug, Squid versions 3.3.0.1 through 5.9 and 6.0 prior to 6.4 compiled using `--with-openssl` are vulnerable to a Denial of Service attack against SSL Certificate validation. This problem allows a remote server to perform Denial of Service against Squid Proxy by initiating a TLS Handshake with a specially crafted SSL Certificate in a server certificate chain. This attack is limited to HTTPS and SSL-Bump. This bug is fixed in Squid version 6.4. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. Those who you use a prepackaged version of Squid should refer to the package vendor for availability information on updated packages.
Faiblesses (CWE)
- CWE-125 — Lecture hors limites
- CWE-129 — Validation incorrecte d'un indice de tableau
- CWE-786 — Access of Memory Location Before Start of Buffer
- CWE-823 — Use of Out-of-range Pointer Offset
- CWE-1285 — Improper Validation of Specified Index, Position, or Offset in Input
- CWE-295 — Validation incorrecte de certificat
Références
- https://github.com/squid-cache/squid/security/advisories/GHSA-73m6-jm96-c6r3
- https://github.com/squid-cache/squid/commit/b70f864940225dfe69f9f653f948e787f99c3810
- http://www.squid-cache.org/Versions/v5/SQUID-2023_4.patch
- http://www.squid-cache.org/Versions/v6/SQUID-2023_4.patch
- https://security.netapp.com/advisory/ntap-20231208-0001/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MEV66D3PAAY6K7TWDT3WZBLCPLASFJDC/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/A5QASTMCUSUEW3UOMKHZJB3FTONWSRXS/
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.6 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H | GitHub_M |
| CVSS 3.1 | HIGH 8.6 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · nvd@nist.gov (Primary) |
Références européennes
- ENISA EUVD · EUVD-2023-50907
- GCVE · GCVE-0-2023-46724
Avis du CERT-FR
- CERTFR-2024-AVI-0354 — Multiples vulnérabilités dans les produits Qnap · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0902 — Vulnérabilité dans Squid · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:squid-cache:squid:*:*:*:*:*:*:*:*≥ 3.3.0.1 < 6.4
Produits affectés
| Produit | Versions |
|---|---|
| squid-cache · squid | affected >= 3.3.0.1, < 6.4 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |